Route Redistribution Lab 1 – Effect of Redistribute Connected

When doing a redistribute connected, One consideration  in using a redistribute connected is the effect of the command in an existing IGP routes.

On this lab, I’m going to present the issue when redistributing a specified interface or connected route and the solution to remediation that issue.

Redistribution-Connected

Pre-Configured  Lab in IOU-Web Format

Obtain IOU-WEB VM from : www.routereflector.com/cisco/cisco-iou-web-interface

Redistribute Connected LAB - IOU-Web Format

Pre-Configured Lab in GNS3 Format

Redistribute Connected LAB - GNS3 Format

Router R1 Initial Configuration

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 12.12.12.1 255.255.255.0
!
router eigrp 12
 network 1.1.1.1 0.0.0.0
 network 12.12.12.1 0.0.0.0

Router R2 Initial Configuration

interface Loopback0
 des eigrp loopback
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
 des ospf loopback
 ip address 2.2.2.22 255.255.255.255
!
interface Ethernet0/0
 des eigrp connected interface
 ip address 12.12.12.2 255.255.255.0
!
interface Ethernet0/1
 des ospf connected interface
 ip address 23.23.23.2 255.255.255.0
!
interface Ethernet0/2
 des connected interface
 ip address 24.24.24.2 255.255.255.0

router eigrp 12
 network 2.2.2.2 0.0.0.0
 network 12.12.12.2 0.0.0.0
 redistribute ospf 23 metric 1 1 1 1 1
!
router ospf 23
 redistribute eigrp 12 subnets
 network 2.2.2.22 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0

Router R3 Initial Configuration

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 ip address 23.23.23.3 255.255.255.0
!
router ospf 23
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0

Routing Table before introducing redistribute connected on R2

R1>show ip route eigrp

      2.0.0.0/32 is subnetted, 2 subnets
D        2.2.2.2 [90/409600] via 12.12.12.2, 00:20:25, Ethernet0/0
D EX     2.2.2.22 [170/2560025856] via 12.12.12.2, 00:12:17, Ethernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
D EX     3.3.3.3 [170/2560025856] via 12.12.12.2, 00:20:25, Ethernet0/0
      23.0.0.0/24 is subnetted, 1 subnets
D EX     23.23.23.0 [170/2560025856] via 12.12.12.2, 00:12:17, Ethernet0/0
R3>show ip route ospf

      1.0.0.0/32 is subnetted, 1 subnets
O E2     1.1.1.1 [110/20] via 23.23.23.2, 00:22:43, Ethernet0/1
      2.0.0.0/32 is subnetted, 2 subnets
O E2     2.2.2.2 [110/20] via 23.23.23.2, 00:04:08, Ethernet0/1
O        2.2.2.22 [110/11] via 23.23.23.2, 00:26:10, Ethernet0/1
      12.0.0.0/24 is subnetted, 1 subnets
O E2     12.12.12.0 [110/20] via 23.23.23.2, 00:04:08, Ethernet0/1
R3#

Introducing redistribute connected on R2

! R2
router ospf 23
 redistribute connected route-map LAN subnet
!
router eigrp 12
 redistribute connected route-map LAN metric 1 1 1 1 1

route-map LAN
 match interface  e0/2

Has resulted on the removal of external route from both IGP

R1 debug ip routing logs
R1#
*Mar 29 20:20:45.989: RT: delete route to 2.2.2.22 via 12.12.12.2, eigrp metric [170/2560025856]
*Mar 29 20:20:45.989: RT: no routes to 2.2.2.22, delayed flush
*Mar 29 20:20:45.989: RT: delete subnet route to 2.2.2.22/32
*Mar 29 20:20:45.989: RT: updating eigrp 2.2.2.22/32 (0x0)  :
    via 12.12.12.2 Et0/0  0 1048578

*Mar 29 20:20:45.989: RT: rib update return code: 5
*Mar 29 20:20:45.989: RT: delete route to 23.23.23.0 via 12.12.12.2, eigrp metric [170/2560025856]
*Mar 29 20:20:45.989: RT: no routes to 23.23.23.0, delayed flush
*Mar 29 20:20:45.989: RT: delete subnet route to 23.23.23.0/24
*Mar 29 20:20:45.989: RT: updating eigrp 23.23.23.0/24 (0x0)  :

R1#    via 12.12.12.2 Et0/0  0 1048578

*Mar 29 20:20:45.989: RT: rib update return code: 5
*Mar 29 20:20:46.005: RT: updating eigrp 24.24.24.0/24 (0x0)  :
    via 12.12.12.2 Et0/0  0 1048578

*Mar 29 20:20:46.005: RT: add 24.24.24.0/24 via 12.12.12.2, eigrp metric [170/2560025856]
R1#

R3 debug ip routing logs
R3#
*Mar 29 20:20:46.967: RT: del 2.2.2.2 via 23.23.23.2, ospf metric [110/20]
*Mar 29 20:20:46.967: RT: delete subnet route to 2.2.2.2/32
*Mar 29 20:20:47.004: RT: del 12.12.12.0 via 23.23.23.2, ospf metric [110/20]
*Mar 29 20:20:47.004: RT: delete subnet route to 12.12.12.0/24
*Mar 29 20:20:47.004: RT: updating ospf 24.24.24.0/24 (0x0)  :
    via 23.23.23.2 Et0/1  0 1048578

*Mar 29 20:20:47.004: RT: add 24.24.24.0/24 via 23.23.23.2, ospf metric [110/20]
R3#

If you have noticed, the route being removed are the route from the redistributed IGP’s

Example the route 2.2.2.2/32 which is a loopback IP address native to OSPF is being removed after the redistribution on the EIGRP process.

to correct this issue we need to update the route-map for the connected route to include the connected interface within the R2 to allow have the correct route to be installed.

Modified route-map for R2

route-map CON-EIGRP permit 10
 match interface Ethernet0/2
route-map CON-EIGRP permit 20
 description OSPF Connected Interface
 match interface Ethernet0/1 Loopback1

route-map CON-OSPF permit 10
 description EIGRP Connected Interface
 match interface Ethernet0/0 Loopback0

router eigrp 12
 redistribute connected metric 1 1 1 1 1 route-map CON-EIGRP
router ospf 23
 redistribute connected subnets route-map CON-OSPF

Resulting Routes which include the missing external route for both IGP’s


R1#show ip route  eigrp

      2.0.0.0/32 is subnetted, 2 subnets
D        2.2.2.2 [90/409600] via 12.12.12.2, 00:45:53, Ethernet0/0
D EX     2.2.2.22 [170/2560025856] via 12.12.12.2, 00:00:31, Ethernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
D EX     3.3.3.3 [170/2560025856] via 12.12.12.2, 00:45:53, Ethernet0/0
      23.0.0.0/24 is subnetted, 1 subnets
D EX     23.23.23.0 [170/2560025856] via 12.12.12.2, 00:00:31, Ethernet0/0
      24.0.0.0/24 is subnetted, 1 subnets
D EX     24.24.24.0 [170/2560025856] via 12.12.12.2, 00:18:04, Ethernet0/0
R1#

R3#show ip ro ospf

      1.0.0.0/32 is subnetted, 1 subnets
O E2     1.1.1.1 [110/20] via 23.23.23.2, 00:55:15, Ethernet0/1
      2.0.0.0/32 is subnetted, 2 subnets
O E2     2.2.2.2 [110/20] via 23.23.23.2, 00:09:53, Ethernet0/1
O        2.2.2.22 [110/11] via 23.23.23.2, 00:58:42, Ethernet0/1
      12.0.0.0/24 is subnetted, 1 subnets
O E2     12.12.12.0 [110/20] via 23.23.23.2, 00:09:53, Ethernet0/1
      24.0.0.0/24 is subnetted, 1 subnets
O E2     24.24.24.0 [110/20] via 23.23.23.2, 00:27:28, Ethernet0/1


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.